Ask Your Question
1

Error: Could not request certificate: Invalid group: 636

asked 2014-05-05 16:03:41 -0500

jathon0815 gravatar image

updated 2014-05-05 16:37:24 -0500

spuder gravatar image

I'm getting this error when I run a freshly installed puppet agent:

root@test:~ # /opt/csw/bin/puppet agent --no-daemonize --verbose --onetime --waitforcert 60
Info: Caching certificate for ca
Error: Could not request certificate: Invalid group: 636

I've checked various directory permissions on the agent's filesystem and on the master's as well. Done more than a few web searches as well. I'm not able to come up with anything that helps. Anyone out there have any pointers that could help me?

edit retag flag offensive close merge delete

Comments

Thanks for the comments, spuder. You got me started in the right direction. Looks like someone had put the puppet user in gid 636 in the /etc/passwd file and I didn't catch that upon my initial look at the file. I've corrected the entry and all is happier in my puppet land now. Thanks!

jathon0815 gravatar imagejathon0815 ( 2014-05-05 18:22:53 -0500 )edit

I've converted my comment into an answer.

spuder gravatar imagespuder ( 2014-05-06 00:31:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-05 16:39:52 -0500

spuder gravatar image

What does `getent group 636` show? Are both machines on LDAP and have identical /etc/passwd files?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-05 16:03:41 -0500

Seen: 127 times

Last updated: May 05 '14