Ask Your Question
0

Error: Could not autoload puppet/provider/package/pear

asked 2014-05-23 08:08:42 -0500

simonrondelez gravatar image

updated 2014-05-23 12:14:28 -0500

Hi

I want to bootstrap my servers with the 14.04 Ubuntu version but I can't seem to get puppet working:

root@test:~# puppet agent --test
Warning: Setting templatedir is deprecated. See http://links.puppetlabs.com/env-settings-deprecations
   (at /usr/lib/ruby/vendor_ruby/puppet/settings.rb:1071:in `each')
Info: Retrieving plugin
Info: Loading facts in /var/lib/puppet/lib/facter/root_home.rb
Info: Loading facts in /var/lib/puppet/lib/facter/facter_dot_d.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_vardir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/concat_basedir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/pe_version.rb
/var/lib/puppet/lib/puppet/provider/package/pear.rb:70: warning: else without rescue is useless
Error: Could not autoload puppet/provider/package/pear: /var/lib/puppet/lib/puppet/provider/package/pear.rb:57: syntax error, unexpected ':', expecting keyword_then or ',' or ';' or '\n'
    when /^INSTALLED/: return nil
                      ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:58: syntax error, unexpected keyword_when, expecting keyword_end
    when /^=/: return nil
        ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:58: syntax error, unexpected ':', expecting keyword_end
    when /^=/: return nil
              ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:59: syntax error, unexpected keyword_when, expecting keyword_end
    when /^PACKAGE/: return nil
        ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:59: syntax error, unexpected ':', expecting keyword_end
    when /^PACKAGE/: return nil
                    ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:60: syntax error, unexpected keyword_when, expecting keyword_end
    when /^(\S+)\s+([.\d]+)\s+\S+\n/
        ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:123: syntax error, unexpected keyword_end, expecting $end
Error: Could not autoload puppet/type/package: Could not autoload puppet/provider/package/pear: /var/lib/puppet/lib/puppet/provider/package/pear.rb:57: syntax error, unexpected ':', expecting keyword_then or ',' or ';' or '\n'
    when /^INSTALLED/: return nil
                      ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:58: syntax error, unexpected keyword_when, expecting keyword_end
    when /^=/: return nil
        ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:58: syntax error, unexpected ':', expecting keyword_end
    when /^=/: return nil
              ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:59: syntax error, unexpected keyword_when, expecting keyword_end
    when /^PACKAGE/: return nil
        ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:59: syntax error, unexpected ':', expecting keyword_end
    when /^PACKAGE/: return nil
                    ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:60: syntax error, unexpected keyword_when, expecting keyword_end
    when /^(\S+)\s+([.\d]+)\s+\S+\n/
        ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:123: syntax error, unexpected keyword_end, expecting $end
Error: Could not retrieve catalog from remote server: Could not intern from text/pson: Could not autoload puppet/type/package: Could not autoload puppet/provider/package/pear: /var/lib/puppet/lib/puppet/provider/package/pear.rb:57: syntax error, unexpected ':', expecting keyword_then or ',' or ';' or '\n'
    when /^INSTALLED/: return nil
                      ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:58: syntax error, unexpected keyword_when, expecting keyword_end
    when /^=/: return nil
        ^
/var/lib/puppet/lib/puppet/provider/package/pear.rb:58 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-30 04:55:20 -0500

Cardil gravatar image

It look to my as an incorrect Ruby version. What is the version there: /usr/lib/ruby/vendor_ruby?

Mayby it just you used invalid version of module? Pear provider is not by default.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-05-23 08:08:42 -0500

Seen: 813 times

Last updated: Nov 30 '14