Ask Your Question
0

SSL Certificate problem [closed]

asked 2014-05-23 08:28:58 -0500

RobN gravatar image

I have puppet cert clean bos-webmock1.comsol.com I have rm ed all ssl on the agent and reinstated the licenses. The license goes to the master and I sign it. The going back to the client to test it again. I get:

Error: Could not request certificate: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed: [self signed certificate in certificate chain for /CN=Puppet CA generated on bos-puppet1.comsol.com at 2014-05-22 16:43:14 -0400]

I have tried to clean everything out, regenerate the SSL, and resign, many times. What else am I missing? The clocks are in sync, they have complete network connection to each other, they are on the same subnet.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by RobN
close date 2014-05-23 12:16:19.235831

Comments

Also I have uninstalled and reinstall different ways (through curl into the server and copying the tgz to the system and running) and when I do the installation never generates a node request on the server. Please help...

RobN gravatar imageRobN ( 2014-05-23 08:38:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-23 10:35:45 -0500

RobN gravatar image

I believe what I was missing was I should simply rm -rf the entire ssl directory instead of just removing the certificates. As this fixed it.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-23 08:28:58 -0500

Seen: 2,369 times

Last updated: May 23 '14