Ask Your Question
0

Error: Could not find a suitable provider for augeas

asked 2014-05-26 09:19:53 -0600

Hristo gravatar image

updated 2014-05-26 09:24:17 -0600

Hello, I seem to be stuck with not being able to use augeas in my vagrant provision environment. I believe I have installed all required libs.

My environments are as follows:

Puppet Master VM (ubuntu 14.04):
puppet - 3.6.1
ruby - 1.9.1
libaugeas-ruby1.9.1
ruby-augeas

Puppet Node VM (ubuntu 14.04):
puppet - 3.5.1
ruby - 1.9.1
ruby-augeas

Hosting Vagrant Machine (ubuntu 14.04):
Vagrant - 1.4.3

Any help on the matter would be appreciated :)

Thank you in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-26 19:53:11 -0600

thunderkeys gravatar image

You might need to install libaugeas-dev as well, so it can compile the gem.

edit flag offensive delete link more

Comments

Tried that, didnt help. Do i need to install it on the Master only or both on the Master and Nodes?

Hristo gravatar imageHristo ( 2014-05-27 01:32:53 -0600 )edit

You'll need it on the nodes as well.

thunderkeys gravatar imagethunderkeys ( 2014-06-05 19:40:52 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-26 09:19:53 -0600

Seen: 1,743 times

Last updated: May 26 '14