Ask Your Question

Error 400 on SERVER: no 'environments'

asked 2014-05-28 00:13:08 -0500

sguiggly gravatar image

I am getting this error after upgrading server to 3.6.1. It was fine under 3.5.1. Running under RHEL6.

Warning: Error 400 on SERVER: no 'environments' in {:current_environment=>#<Puppet::Node::Environment:0x7fc2eac2cb58 @modulepath=[], @watching=true, @config_version=nil, @manifest="/", @name=:"*root*">, :root_environment=>#<Puppet::Node::Environment:0x7fc2eac2cb58 @modulepath=[], @watching=true, @config_version=nil, @manifest="/", @name=:"*root*">} at top of [[0, nil, nil]]

The puppet.conf on my server looks like:

  logdir = /var/log/puppet
  vardir = /var/lib/puppet
  rundir = /var/run/puppet
  pluginsync = true
  server = myserver
  certificate_revocation = false

  reports = http,puppetdb
  reporturl =
  node_terminus = exec
  external_nodes = /usr/bin/env PUPPET_DASHBOARD_URL= /usr/share/puppet-dashboard/bin/external_node
  storeconfigs = true
  storeconfigs_backend = puppetdb
  certname = puppetmaster
  environmentpath = /etc/puppet/environments


I definitely have an environments directory with environments matching the client...I know this as it is exactly how I did it under 3.5.1!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-05-28 13:35:48 -0500

edit flag offensive delete link more

answered 2014-05-28 03:06:46 -0500

daff gravatar image

Your are probably running the Puppet master under WEBrick? This is a concurrency issue, tracked in .

A workaround is to run the Puppet master under Apache and Passenger, which is the preferred and recommended way for any non-trivial, productive Puppet deployment.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-05-28 00:13:08 -0500

Seen: 898 times

Last updated: May 28 '14