Debian package epoch number causing issues

asked 2014-05-28 13:34:12 -0500

mstanislav gravatar image

On Puppet 3.2.4 I'm able to have a package installed from an apt repository fine using "ensure => latest". However, when the same system is provisioned again, I receive:

Notice: /Stage[main]/XXXX::Apt/Package[yyyy]/ensure: ensure changed '1.9.11-0' to '0:1.9.11-0'

The package with dpkg -l shows up as 1.9.11-0 and in apt-cache showpkg I see 0:1.9.11-0. This should all be fine as epoch values (the number before the colon) are handled as expected with typical usage of apt/dpkg.

Anyone know how to prevent this issue while still using "latest" for the ensure statement?

edit retag flag offensive close merge delete