Ask Your Question
0

Dashboard can't process pending tasks when using Apache Passenger

asked 2014-05-30 15:28:19 -0500

Pindish gravatar image

I am using open source Puppet 3.6.1 and Dashboard 1.2.23 on Debian 7.5 x86_64. I have Puppet master, PuppetDB, and Puppet Dashboard running on separate boxes. Puppet master and agents are working fine.

For Puppet Dashboard, for some reason it CANNOT process any pending tasks when using Apache Passenger. When I disable the puppetdashboard virtual host in Apache2, and switch back to use the puppet-dashboard and puppet-dashboard-workers services, pending tasks are processed correctly.

Here is the screenshot for Dashboard using Passenger:

image description

Per 'passenger-status', the puppet-dashboard Rake app is running. However, it does not process any pending tasks.

root@puppetdashboard:~# passenger-status 
----------- General information -----------
max      = 12
count    = 1
active   = 0
inactive = 1
Waiting on global queue: 0

----------- Application groups -----------
/usr/share/puppet-dashboard:
  App root: /usr/share/puppet-dashboard
  * PID: 4374    Sessions: 0    Processed: 1       Uptime: 24s

Here is my puppetdashboard virtual host definition:

PassengerRuby /usr/bin/ruby1.8
PassengerHighPerformance on
PassengerMaxPoolSize 12
PassengerPoolIdleTime 1500
PassengerStatThrottleRate 120
RailsAutoDetect On

Listen 3000

<VirtualHost *:3000>
        ServerName dashboard.localdomain
        DocumentRoot /usr/share/puppet-dashboard/public/
        <Directory /usr/share/puppet-dashboard/public/>
                Options None
                Order allow,deny
                allow from all
        </Directory>
  ErrorLog /var/log/apache2/dashboard_error.log
  LogLevel warn
  CustomLog /var/log/apache2/dashboard_access.log combined
  ServerSignature On
</VirtualHost>

What maybe the root cause?

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-06-05 19:36:06 -0500

thunderkeys gravatar image

As far as I know, you still have to run the puppet-dashboard-workers service, even when running puppet-dashboard under passenger. That's how we have it setup with dashboard 1.2.x at least (with puppet-dashbaord running under passenger).

edit flag offensive delete link more

Comments

Thats correct, you need the Setup puppet-dashboard through Apache with Passenger and disable the autostart of puppet-dashboard. But you still need to have the service puppet-dashboard-workers enabled, they are still working the queue of pending tasks.

Dennis Philpot gravatar imageDennis Philpot ( 2014-06-06 10:29:11 -0500 )edit
0

answered 2014-06-06 18:49:41 -0500

Pindish gravatar image

Thanks! Running puppet-dashboard thru Apache Passenger + puppet-dashboard-workers service work fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-30 15:28:19 -0500

Seen: 616 times

Last updated: Jun 06 '14