Ask Your Question
1

Will there be package type support for pkgin (pkgsrc) on SmartOS?

asked 2013-04-10 15:17:15 -0500

scarcry gravatar image

I'm running 2.7.21 on SmartOS which uses pkgin as it's package manager. I'd love to see SmartOS supported as a platform so that I can let puppet install packages using the pkgin utility.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-04-10 15:40:39 -0500

jonn gravatar image

Looks like some enterprising person has done this :) Click here to see the module on Puppet Forge

It looks like it has been merged as well, so it should be turning up in Puppet core at some point.

edit flag offensive delete link more

Comments

2

Looks like it was released in Puppet 3.0.0.

domcleal gravatar imagedomcleal ( 2013-04-10 15:43:56 -0500 )edit

that's great, looks like I'm going to provision another zone for a 2nd master and deploy 3.1.1 there for some experimentation.

scarcry gravatar imagescarcry ( 2013-04-12 05:01:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-10 15:17:15 -0500

Seen: 647 times

Last updated: Apr 10 '13