Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Error: Could not retrieve plugin: execution expired

Hi ,

I am running puppet client version 3.6.2 puppet server - 3.5.1-1puppetlabs1

When I am trying to install new hosts ( only on new hosts ) I am getting this error in the end of the "puppet agent --test " command when trying to load configuration from command line

my puppet.conf client file looks like this :

root@runtime3-zone-a:/home/admin# cat /etc/puppet/puppet.conf [main] server = puppet-master.prod.capriza.com logdir=/var/log/puppet vardir=/var/lib/puppet ssldir=/var/lib/puppet/ssl rundir=/var/run/puppet factpath=$vardir/lib/facter

templatedir=$confdir/templates

configtimeout=5m

prerun_command=/etc/puppet/etckeeper-commit-pre

postrun_command=/etc/puppet/etckeeper-commit-post

#

Environment selection - choose ONE from below, without the <>

# environment=qa

confdir = /etc/puppet certificate_revocation = false

[agent] server = puppet-master.prod.capriza.com report = true runinterval=5m certname=runtime3-zone-a.test.capriza.com

[master]

These are needed when the puppetmaster is run by passenger

and can safely be removed if webrick is used.

ssl_client_header = SSL_CLIENT_S_DN ssl_client_verify_header = SSL_CLIENT_VERIFY

This is the error I am getting : ( when trying to run the puppet agent --test , after several times it manage to run ok . but only on the first several tries it faild ...

Info: Retrieving plugin Notice: /File[/var/lib/puppet/lib/puppet]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/provider]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/provider/file_line]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/util]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/util/ipcidr.rb]/ensure: defined content as '{md5}225adf61f5de40fa04b4e936e388b801' Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall.rb]/ensure: defined content as '{md5}f4c747685c2c8ef97fe78732c8153c75' Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall/iptables.rb]/ensure: defined content as '{md5}09095f4df985ff6beea50e8db5c36fb7' Notice: /File[/var/lib/puppet/lib/puppet/parser]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/parser/functions]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/ensure_packages.rb]/ensure: defined content as '{md5}ca852b2441ca44b91a984094de4e3afc' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_hash.rb]/ensure: defined content as '{md5}e9cfaca68751524efe16ecf2f958a9a0' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_bool.rb]/ensure: defined content as '{md5}4ddffdf5954b15863d18f392950b88f4' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/url_parse.rb]/ensure: defined content as '{md5}71d6f11070d1dc00f3dcad71a23f570a' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/get_module_path.rb]/ensure: defined content as '{md5}d4bf50da25c0b98d26b75354fa1bcc45' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_ip_address.rb]/ensure: defined content as '{md5}a53f6e3a5855954148230846ccb3e04d' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_numeric.rb]/ensure: defined content as '{md5}6283dd52935fb1aba41958e50c85b1ed' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/delete.rb]/ensure: defined content as '{md5}9b17b9f7f820adf02360147c1a2f4279' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_domain_name.rb]/ensure: defined content as '{md5}fba9f855df3bbf90d72dfd5201f65d2b' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_ip_address.rb]/ensure: defined content as '{md5}ee207f47906455a5aa49c4fb219dd325' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_absolute_path.rb]/ensure: defined content as '{md5}385137ac24a2dec6cecc4e6ea75be442' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_key.rb]/ensure: defined content as '{md5}7cd9728c38f0b0065f832dabd62b0e7e' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/flatten.rb]/ensure: defined content as '{md5}251d63696564254d41742ecbfbfcb9fd' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/max.rb]/ensure: defined content as '{md5}02975799d44ded069c1a0769cbf8b73b' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_ip_network.rb]/ensure: defined content as '{md5}b4d726c8b2a0afac81ced8a3a28aa731' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_mac_address.rb]/ensure: defined content as '{md5}288bd4b38d4df42a83681f13e7eaaee0' Error: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_array.rb]/ensure: change from absent to file failed: execution expired Error: Could not retrieve plugin: execution expired

Error: Could not retrieve plugin: execution expired

Hi ,

I am running puppet client version 3.6.2 puppet server - 3.5.1-1puppetlabs1

When I am trying to install new hosts ( only on new hosts ) I am getting this error in the end of the "puppet agent --test " command when trying to load configuration from command line

my puppet.conf client file looks like this :

root@runtime3-zone-a:/home/admin# cat /etc/puppet/puppet.conf [main] server = puppet-master.prod.capriza.com logdir=/var/log/puppet vardir=/var/lib/puppet ssldir=/var/lib/puppet/ssl rundir=/var/run/puppet factpath=$vardir/lib/facter

templatedir=$confdir/templates

configtimeout=5m

prerun_command=/etc/puppet/etckeeper-commit-pre

postrun_command=/etc/puppet/etckeeper-commit-post

#

Environment selection - choose ONE from below, without the <>

# environment=qa

confdir = /etc/puppet certificate_revocation = false

[agent] server = puppet-master.prod.capriza.com report = true runinterval=5m certname=runtime3-zone-a.test.capriza.com

[master]

These are needed when the puppetmaster is run by passenger

and can safely be removed if webrick is used.

ssl_client_header = SSL_CLIENT_S_DN ssl_client_verify_header = SSL_CLIENT_VERIFY

This is the error I am getting : ( when trying to run the puppet agent --test , after several times it manage to run ok . but only on the first several tries it faild ...

Info: Retrieving plugin Notice: /File[/var/lib/puppet/lib/puppet]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/provider]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/provider/file_line]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/util]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/util/ipcidr.rb]/ensure: defined content as '{md5}225adf61f5de40fa04b4e936e388b801' Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall.rb]/ensure: defined content as '{md5}f4c747685c2c8ef97fe78732c8153c75' Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall/iptables.rb]/ensure: defined content as '{md5}09095f4df985ff6beea50e8db5c36fb7' Notice: /File[/var/lib/puppet/lib/puppet/parser]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/parser/functions]/ensure: created Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/ensure_packages.rb]/ensure: defined content as '{md5}ca852b2441ca44b91a984094de4e3afc' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_hash.rb]/ensure: defined content as '{md5}e9cfaca68751524efe16ecf2f958a9a0' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_bool.rb]/ensure: defined content as '{md5}4ddffdf5954b15863d18f392950b88f4' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/url_parse.rb]/ensure: defined content as '{md5}71d6f11070d1dc00f3dcad71a23f570a' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/get_module_path.rb]/ensure: defined content as '{md5}d4bf50da25c0b98d26b75354fa1bcc45' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_ip_address.rb]/ensure: defined content as '{md5}a53f6e3a5855954148230846ccb3e04d' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_numeric.rb]/ensure: defined content as '{md5}6283dd52935fb1aba41958e50c85b1ed' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/delete.rb]/ensure: defined content as '{md5}9b17b9f7f820adf02360147c1a2f4279' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_domain_name.rb]/ensure: defined content as '{md5}fba9f855df3bbf90d72dfd5201f65d2b' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_ip_address.rb]/ensure: defined content as '{md5}ee207f47906455a5aa49c4fb219dd325' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_absolute_path.rb]/ensure: defined content as '{md5}385137ac24a2dec6cecc4e6ea75be442' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_key.rb]/ensure: defined content as '{md5}7cd9728c38f0b0065f832dabd62b0e7e' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/flatten.rb]/ensure: defined content as '{md5}251d63696564254d41742ecbfbfcb9fd' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/max.rb]/ensure: defined content as '{md5}02975799d44ded069c1a0769cbf8b73b' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_ip_network.rb]/ensure: defined content as '{md5}b4d726c8b2a0afac81ced8a3a28aa731' Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_mac_address.rb]/ensure: defined content as '{md5}288bd4b38d4df42a83681f13e7eaaee0' Error: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_array.rb]/ensure: change from absent to file failed: execution expired Error: Could not retrieve plugin: execution expired

Error: Could not retrieve plugin: execution expired

Hi ,

I am running puppet client version 3.6.2 puppet server - 3.5.1-1puppetlabs1

When I am trying to install new hosts ( only on new hosts ) I am getting this error in the end of the "puppet puppet agent --test " --test command when trying to load configuration from command line

my puppet.conf client file looks like this :

root@runtime3-zone-a:/home/admin# cat /etc/puppet/puppet.conf 
[main]
server = puppet-master.prod.capriza.com
logdir=/var/log/puppet
vardir=/var/lib/puppet
ssldir=/var/lib/puppet/ssl
rundir=/var/run/puppet
factpath=$vardir/lib/facter

templatedir=$confdir/templates

configtimeout=5m

prerun_command=/etc/puppet/etckeeper-commit-pre

postrun_command=/etc/puppet/etckeeper-commit-post

#

factpath=$vardir/lib/facter #templatedir=$confdir/templates configtimeout=5m #prerun_command=/etc/puppet/etckeeper-commit-pre #postrun_command=/etc/puppet/etckeeper-commit-post # # Environment selection - choose ONE from below, without the <>

<> # environment=qa

environment=qa confdir = /etc/puppet certificate_revocation = false

false [agent] server = puppet-master.prod.capriza.com report = true runinterval=5m certname=runtime3-zone-a.test.capriza.com

[master]

certname=runtime3-zone-a.test.capriza.com [master] # These are needed when the puppetmaster is run by passenger

passenger # and can safely be removed if webrick is used.

used. ssl_client_header = SSL_CLIENT_S_DN ssl_client_verify_header = SSL_CLIENT_VERIFY

SSL_CLIENT_VERIFY

This is the error I am getting : ( when trying to run the puppet agent --test , after several times it manage to run ok . but only on the first several tries it faild ...

Info: Retrieving plugin
Notice: /File[/var/lib/puppet/lib/puppet]/ensure: created
Notice: /File[/var/lib/puppet/lib/puppet/provider]/ensure: created
Notice: /File[/var/lib/puppet/lib/puppet/provider/file_line]/ensure: created
Notice: /File[/var/lib/puppet/lib/puppet/util]/ensure: created
Notice: /File[/var/lib/puppet/lib/puppet/util/ipcidr.rb]/ensure: defined content as '{md5}225adf61f5de40fa04b4e936e388b801'
Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall.rb]/ensure: defined content as '{md5}f4c747685c2c8ef97fe78732c8153c75'
Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall]/ensure: created
Notice: /File[/var/lib/puppet/lib/puppet/provider/firewall/iptables.rb]/ensure: defined content as '{md5}09095f4df985ff6beea50e8db5c36fb7'
Notice: /File[/var/lib/puppet/lib/puppet/parser]/ensure: created
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions]/ensure: created
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/ensure_packages.rb]/ensure: defined content as '{md5}ca852b2441ca44b91a984094de4e3afc'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_hash.rb]/ensure: defined content as '{md5}e9cfaca68751524efe16ecf2f958a9a0'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_bool.rb]/ensure: defined content as '{md5}4ddffdf5954b15863d18f392950b88f4'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/url_parse.rb]/ensure: defined content as '{md5}71d6f11070d1dc00f3dcad71a23f570a'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/get_module_path.rb]/ensure: defined content as '{md5}d4bf50da25c0b98d26b75354fa1bcc45'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_ip_address.rb]/ensure: defined content as '{md5}a53f6e3a5855954148230846ccb3e04d'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_numeric.rb]/ensure: defined content as '{md5}6283dd52935fb1aba41958e50c85b1ed'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/delete.rb]/ensure: defined content as '{md5}9b17b9f7f820adf02360147c1a2f4279'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_domain_name.rb]/ensure: defined content as '{md5}fba9f855df3bbf90d72dfd5201f65d2b'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_ip_address.rb]/ensure: defined content as '{md5}ee207f47906455a5aa49c4fb219dd325'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_absolute_path.rb]/ensure: defined content as '{md5}385137ac24a2dec6cecc4e6ea75be442'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_key.rb]/ensure: defined content as '{md5}7cd9728c38f0b0065f832dabd62b0e7e'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/flatten.rb]/ensure: defined content as '{md5}251d63696564254d41742ecbfbfcb9fd'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/max.rb]/ensure: defined content as '{md5}02975799d44ded069c1a0769cbf8b73b'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/has_ip_network.rb]/ensure: defined content as '{md5}b4d726c8b2a0afac81ced8a3a28aa731'
Notice: /File[/var/lib/puppet/lib/puppet/parser/functions/is_mac_address.rb]/ensure: defined content as '{md5}288bd4b38d4df42a83681f13e7eaaee0'
Error: /File[/var/lib/puppet/lib/puppet/parser/functions/validate_array.rb]/ensure: change from absent to file failed: execution expired
Error: Could not retrieve plugin: execution expired

expired