Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

address already in use bind(2)??

Hi All, I'm setting up puppetmaster using linux mint Below is the error. After much google I can't find any answer.

sudo puppet master --verbose --no-daemonize Warning: Setting templatedir is deprecated. See http://links.puppetlabs.com/env-settings-deprecations (at /usr/lib/ruby/vendor_ruby/puppet/settings.rb:1134:in `issue_deprecation_warning') Notice: Starting Puppet master version 3.7.2 Error: Could not run: Address already in use - bind(2)

address already in use bind(2)??

Hi All, I'm setting up puppetmaster using linux mint Below is the error. After much google I can't find any answer.

sudo puppet master --verbose --no-daemonize Warning: Setting templatedir is deprecated. See http://links.puppetlabs.com/env-settings-deprecations (at /usr/lib/ruby/vendor_ruby/puppet/settings.rb:1134:in `issue_deprecation_warning') Notice: Starting Puppet master version 3.7.2 Error: Could not run: Address already in use - bind(2)

*note: the linuxmint is freshly installed. No other puppetmasters or clients are running during this error occur.

address already in use bind(2)??

Hi All,

I'm setting up puppetmaster using linux mint Below is the error. After much google I can't find any answer.

sudo puppet master --verbose --no-daemonize
Warning: Setting templatedir is deprecated. See http://links.puppetlabs.com/env-settings-deprecations
   (at /usr/lib/ruby/vendor_ruby/puppet/settings.rb:1134:in `issue_deprecation_warning')
Notice: Starting Puppet master version 3.7.2
Error: Could not run: Address already in use - bind(2)

bind(2)

*note: the linuxmint is freshly installed. No other puppetmasters or clients are running during this error occur.