Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Could not find dependency User root for File

Hello,

I believe I'm trying to so something very simple, but it's not working. I have a set of directories that I want to ensure are present with the proper ownership, so I define them all upfront and then realize them where I need to make sure they are present. When I use require User['root'] or Group['root'] in the virtual definition, I get a "Could not find dependency" error.

Example:

@file { "/home":
    owner               =>  'root',
    group                =>  'root',
    mode                =>  0755,
    require              =>  [ User['root'], Group['root'] ],
}

This may very well be a newbie type issue, but I've read and read and tried and tried and I must be missing something really simple, because this cannot be a very complicated objective.

Also, if I do a "puppet resource user root", of course the root user is found.

user { 'root':
  ensure           => 'present',
  comment          => 'root',
  gid              => '0',
  home             => '/root',
  password         => '<removed for security>',
  password_max_age => '99999',
  password_min_age => '0',
  shell            => '/bin/bash',
  uid              => '0',
}

thanks, Stephen