About | FAQ | Help
Ask Your Question

Revision history [back]

Unable to use default installer to install Puppet Enterprise

I thought I would give Enterprise a test whirl, but I'm getting the following error (seems like a dead link in the installer).

Error: curl -f -L -o puppet-agent-ubuntu-14.04-amd64.tar.gz https://pm.puppetlabs.com/puppet-agent/2015.2.3/1.3.0/repos/puppet-agent-ubuntu-14.04-amd64.tar.gz returned 22 instead of one of [0] Error: /Stage[main]/Pe_repo::Platform::Ubuntu_1404_amd64/Pe_repo::Debian[ubuntu-14.04-amd64]/Pe_repo::Repo[ubuntu-14.04-amd64 2015.2.3]/Pe_staging::Deploy[puppet-agent-ubuntu-14.04-amd64.tar.gz]/Pe_staging::File[puppet-agent-ubuntu-14.04-amd64.tar.gz]/Exec[/opt/puppetlabs/server/data/staging/pe_repo-puppet-agent-1.3.0/puppet-agent-ubuntu-14.04-amd64.tar.gz]/returns: change from notrun to 0 failed: curl -f -L -o puppet-agent-ubuntu-14.04-amd64.tar.gz https://pm.puppetlabs.com/puppet-agent/2015.2.3/1.3.0/repos/puppet-agent-ubuntu-14.04-amd64.tar.gz returned 22 instead of one of [0] Warning: /Stage[main]/Pe_repo::Platform::Ubuntu_1404_amd64/Pe_repo::Debian[ubuntu-14.04-amd64]/Pe_repo::Repo[ubuntu-14.04-amd64 2015.2.3]/Pe_staging::Deploy[puppet-agent-ubuntu-14.04-amd64.tar.gz]/Pe_staging::Extract[puppet-agent-ubuntu-14.04-amd64.tar.gz]/Exec[extract puppet-agent-ubuntu-14.04-amd64.tar.gz]: Skipping because of failed dependencies

curl -f -L -o puppet-agent-ubuntu-14.04-amd64.tar.gz https://pm.puppetlabs.com/puppet-agent/2015.2.3/1.3.0/repos/puppet-agent-ubuntu-14.04-amd64.tar.gz % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 293 100 293 0 0 611 0 --:--:-- --:--:-- --:--:-- 612 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0