Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

YAML in network requests is not supported

Hi there! I use Puppet Master 4.3.1 and puppet agent 2.7.26 on centos 6.4 and i get an error:

    [root@ids1-chel1 iglov]# puppet agent --debug --no-daemonize --onetime
    ...
    debug: Finishing transaction 69820138715160
    debug: catalog supports formats: b64_zlib_yaml dot pson raw yaml; using pson
    debug: Using cached certificate for ca
    debug: Using cached certificate for ids1-chel1.is74.ru
    debug: Using cached certificate_revocation_list for ca
    err: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not intern from b64_zlib_yaml: No format match the given format name or mime-type (b64_zlib_yaml)
    notice: Using cached catalog
    err: Could not retrieve catalog; skipping run
    debug: report supports formats: b64_zlib_yaml pson raw yaml; using pson
    err: Could not send report: Error 400 on SERVER: YAML in network requests is not supported. See http://links.puppetlabs.com/deprecate_yaml_on_network

Yes, i see http://links.puppetlabs.com/deprecate_yaml_on_network but i can't understand, how can i use old version of puppet agent (2.7) with new version Puppet Master (4.3.1)?

YAML in network requests is not supported

Hi there! I use Puppet Master 4.3.1 and puppet agent 2.7.26 on centos 6.4 and i get an error:

    [root@ids1-chel1 iglov]# puppet agent --debug --no-daemonize --onetime
    ...
    debug: Finishing transaction 69820138715160
    debug: catalog supports formats: b64_zlib_yaml dot pson raw yaml; using pson
    debug: Using cached certificate for ca
    debug: Using cached certificate for ids1-chel1.is74.ru
    debug: Using cached certificate_revocation_list for ca
    err: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not intern from b64_zlib_yaml: No format match the given format name or mime-type (b64_zlib_yaml)
    notice: Using cached catalog
    err: Could not retrieve catalog; skipping run
    debug: report supports formats: b64_zlib_yaml pson raw yaml; using pson
    err: Could not send report: Error 400 on SERVER: YAML in network requests is not supported. See http://links.puppetlabs.com/deprecate_yaml_on_network

Yes, i see http://links.puppetlabs.com/deprecate_yaml_on_network this issue but i can't understand, how can i use old version of puppet agent (2.7) with new version Puppet Master (4.3.1)?

YAML in network requests is not supported

Hi there! I use Puppet Master 4.3.1 and puppet agent 2.7.26 on centos 6.4 and i get an error:

    [root@ids1-chel1 iglov]# puppet agent --debug --no-daemonize --onetime
    ...
    debug: Finishing transaction 69820138715160
    debug: catalog supports formats: b64_zlib_yaml dot pson raw yaml; using pson
    debug: Using cached certificate for ca
    debug: Using cached certificate for ids1-chel1.is74.ru
    debug: Using cached certificate_revocation_list for ca
    err: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not intern from b64_zlib_yaml: No format match the given format name or mime-type (b64_zlib_yaml)
    notice: Using cached catalog
    err: Could not retrieve catalog; skipping run
    debug: report supports formats: b64_zlib_yaml pson raw yaml; using pson
    err: Could not send report: Error 400 on SERVER: YAML in network requests is not supported. See http://links.puppetlabs.com/deprecate_yaml_on_network

Yes, i see this issue but i can't understand, how can i use old version of puppet agent (2.7) with new version Puppet Master (4.3.1)?(4.3)?