Ask Your Question

Revision history [back]

I am getting following error while running puppet apply

Error: Validation of Exec[extract_tomcat] failed: 'gunzip apache-tomcat.tar.gz' is not qualified and no path was specified. Please qualify the command or specify a path. at /opt/SP/jboss/home/.puppetlabs/etc/code/environments/shilpi/modules/tomcatbe/manifests/init.pp:57 Following is the init.pp file:

class tomcatbe {

file {'/opt/SP/apps/tomcatbe/apache-tomcat.tar.gz': ensure => 'present', source => '/var/SP/data/puppet/fileserver_data/tomcatbe/apache-tomcat.tar.gz', owner => 'jboss', group => 'jboss', mode => '750', before => Exec['extract_tomcat'],

}

exec {'extract_tomcat': cwd => '/opt/SP/apps/tomcatbe/', command => 'gunzip apache-tomcat.tar.gz', } }

click to hide/show revision 2
None

I am getting following error while running puppet apply

output

Error: Validation of Exec[extract_tomcat] failed: 'gunzip  apache-tomcat.tar.gz' is not qualified and no path was specified. Please qualify the command or specify a path. at /opt/SP/jboss/home/.puppetlabs/etc/code/environments/shilpi/modules/tomcatbe/manifests/init.pp:57

Following is the init.pp file:

 class tomcatbe {

{ file {'/opt/SP/apps/tomcatbe/apache-tomcat.tar.gz': ensure => 'present', source => '/var/SP/data/puppet/fileserver_data/tomcatbe/apache-tomcat.tar.gz', owner => 'jboss', group => 'jboss', mode => '750', before => Exec['extract_tomcat'],

}

Exec['extract_tomcat'], } exec {'extract_tomcat': cwd => '/opt/SP/apps/tomcatbe/', command => 'gunzip apache-tomcat.tar.gz', } }

}