Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Solaris : augeas issue

Hello dear puppeteers,

I am currently facing an issue on a Solaris platform while trying to modify a file using an augeas resource

augeas { "sudo_${username}":
        context => '/files/etc/sudoers',
        changes => [
          "defnode user spec[user='${username}'] ''",
          "set \$user/user '${username}'",
          [...]
         ],

The following errors occur when this code is executed :

Debug: Puppet::Type::Augeas::ProviderAugeas: feature augeas is missing
Error: Could not find a suitable provider for augeas

Does anyone have any clue about the root cause of this issue ?

Thanks beforehand !

Solaris : augeas issue

Hello dear puppeteers,

I am currently facing an issue on a Solaris platform while trying to modify a file using an augeas resource

augeas { "sudo_${username}":
        context => '/files/etc/sudoers',
        changes => [
          "defnode user spec[user='${username}'] ''",
          "set \$user/user '${username}'",
          [...]
         ],

The following errors occur when this code is executed :

Debug: Puppet::Type::Augeas::ProviderAugeas: feature augeas is missing
Error: Could not find a suitable provider for augeas

Does anyone have any clue about the root cause of this issue ?

NB : running Puppet 4.8.2 using the dedicated gem

Thanks beforehand !

Solaris : augeas issue

Hello dear puppeteers,

I am currently facing an issue on a Solaris platform while trying to modify a file using an augeas resource

augeas { "sudo_${username}":
        context => '/files/etc/sudoers',
        changes => [
          "defnode user spec[user='${username}'] ''",
          "set \$user/user '${username}'",
          [...]
         ],

The following errors occur when this code is executed :

Debug: Puppet::Type::Augeas::ProviderAugeas: feature augeas is missing
Error: Could not find a suitable provider for augeas

Does anyone have any clue about the root cause of this issue ?

NB : running Puppet 4.8.2 using the dedicated gemgem, on a Solaris 11 machine

Thanks beforehand !