Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Install RPM built with FPM and dependencies

Hi,

Hopefully someone can help as I am new to Puppet.

We are running version 3.6.2 (Puppet Enterprise 3.3.2) and I am looking to install an RPM that I created using FPM which requires a number of dependencies.

Would someone be able to advise how I would accomplish this as with it being an RPM that I have created the dependencies won't automatically be resolved.

I have created the below but it doesn't seem to work and I get no error output.

package { 'Oracle_Client': ensure => '11.2.0.1-1', require => [Package['compat-libcap1-1.10-7.el7'], Package['elfutils-libelf-devel-0.168-8.el7'], Package['gcc-4.8.5-16.el7'], Package['gcc-c++-4.8.5-16.el7'], Package['glibc-devel-2.17-196.el7'], Package['glibc-headers-2.17-196.el7'], Package['libaio-devel-0.3.109-13.el7'], Package['libstdc++-4.8.5-16.el7'], Package['libstdc++-devel-4.8.5-16.el7'], Package['numactl-devel-2.0.9-6.el7_2'], Package['sysstat-10.1.5-12.el7'], Package['libXi-1.7.9-1.el7'], Package['libXtst-1.2.3-1.el7']], }

Thanks

click to hide/show revision 2
None

Install RPM built with FPM and dependencies

Hi,

Hopefully someone can help as I am new to Puppet.

We are running version 3.6.2 (Puppet Enterprise 3.3.2) and I am looking to install an RPM that I created using FPM which requires a number of dependencies.

Would someone be able to advise how I would accomplish this as with it being an RPM that I have created the dependencies won't automatically be resolved.

I have created the below but it doesn't seem to work and I get no error output.

 package { 'Oracle_Client':
      ensure => '11.2.0.1-1',
      require => [Package['compat-libcap1-1.10-7.el7'], Package['elfutils-libelf-devel-0.168-8.el7'], Package['gcc-4.8.5-16.el7'], Package['gcc-c++-4.8.5-16.el7'], Package['glibc-devel-2.17-196.el7'], Package['glibc-headers-2.17-196.el7'], Package['libaio-devel-0.3.109-13.el7'], Package['libstdc++-4.8.5-16.el7'], Package['libstdc++-devel-4.8.5-16.el7'], Package['numactl-devel-2.0.9-6.el7_2'], Package['sysstat-10.1.5-12.el7'], Package['libXi-1.7.9-1.el7'], Package['libXtst-1.2.3-1.el7']],
    }

}

Thanks