Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Puppet server disable "webserver" because i am using apache

Hello ,

OS : centos 7.4.1708 , kernel 3.10.0-693.5.2.el7.x86_64

Puppetserver : puppetserver-1.2.0-1.el7.noarch, puppet version : 3.8.7

I have a vhost on apache to handle the requests on port 8140 , but this puppet server keeps wanting to listen to port 8140 too , and if i delete "/etc/puppetserver/conf.d/webserver.conf" then i get other sorts of errors , like ssl-host and ssl-port not set or whatever .

How can i disable the "webserver" and let know puppet that i already have apache listenintg on 8140 with passenger module setup ?

Best Regards .