Ask Your Question

Revision history [back]

Installed PuppetMaster, cannot find puppet.conf file in /etc

Installed PuppetMaster, cannot find puppet.conf --> Finished Dependency Resolution Error: Package: 1:ruby-shadow-2.2.0-2.el7.x86_64 (puppetlabs-deps) Requires: libruby.so.2.0()(64bit) Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps) Requires: libruby.so.2.0()(64bit) Error: Package: puppet-3.8.7-1.el7.noarch (puppetlabs-products) Requires: systemd Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps) Requires: ruby(release) = 2.0.0 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest [root@localhost ~]#

Kindly advise

click to hide/show revision 2
None

Installed PuppetMaster, cannot find puppet.conf file in /etc

.

 Installed PuppetMaster, cannot find puppet.conf
--> Finished Dependency Resolution
Error: Package: 1:ruby-shadow-2.2.0-2.el7.x86_64 (puppetlabs-deps)
           Requires: libruby.so.2.0()(64bit)
Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps)
           Requires: libruby.so.2.0()(64bit)
Error: Package: puppet-3.8.7-1.el7.noarch (puppetlabs-products)
           Requires: systemd
Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps)
           Requires: ruby(release) = 2.0.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@localhost ~]#

~]#

Kindly advise advise