Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Override noop when set in a type

Hello,

Is there a way to override noop if its set within a type? Looks like --no-noop has no effect in this scenario. I see this as a feature request but has been closed: http://projects.puppetlabs.com/issues/682

Ex: class blah { exec { danger: noop => true, tag => hitme, command => "might_break_it", path => "/bin:/usr/bin:/usr/local/bin", logoutput => true } }

I should be able to override the above setting with: puppet agent -t --no-noop, but looks like it doesn't work. I am using Puppet 3.1

Any chance this may be revisited or if there are any workarounds?