Ask Your Question

TomSchenk's profile - activity

2016-02-29 18:37:46 -0600 received badge  Popular Question (source)
2016-02-29 18:37:46 -0600 received badge  Notable Question (source)
2016-02-29 18:37:46 -0600 received badge  Famous Question (source)
2015-03-19 14:03:18 -0600 asked a question Solaris 9 and 3.7

I am looking to implement Puppet Enterprise 3.7.x in our environments, but am concerned about the compatability matrix that indicates that it is only supported on Solaris 10.9 ad later. We still have a few Solaris systems running versions prior to that.

I have heard a couple of different reasons why this version requirement exists, firstly that there is a dependency on Ruby that can't be satisfied on earlier versions of Solaris, or that there is actually some other dependency (such as a dependency on zone support in the OS kernel), but I can't find a definitive answer.

Not being able to support my older solaris nodes is a serious concern and I need to be able to run at least version 3.0 in order to implement what I need to implement.

does anyone know where I can find this asnwer?